Entender el error
El importador de contactos de Kajabi requiere que los archivos CSV usen codificación UTF-8 para importarse correctamente. El motivo más común de este error es que un carácter que no es UTF-8, como “Å”, esté presente en el archivo .csv. Para subir tu archivo .csv con éxito, deberás abrirlo y cambiar el tipo de archivo. Los pasos varían según si usas Excel en Windows o Numbers en macOS.Formato en Windows
- Abre tu .csv en Excel.
Nota: Si usas un programa de hojas de cálculo diferente, consulta su documentación de soporte para conocer las instrucciones sobre cómo descargar como CSV UTF-8.
- Selecciona File y haz clic en Save As.
- En el menú desplegable de tipo de archivo, selecciona CSV UTF-8 (delimitado por comas) (*.csv).
- Haz clic en Save.
Formato en macOS
- Abre tu .csv en Numbers.
- Selecciona File.
- Selecciona Export To, luego selecciona .csv.
- En las opciones de exportación, selecciona Advanced Options y especifica Unicode (UTF-8). Si se muestra otra opción de exportación de .csv, haz clic en el menú desplegable y elige Unicode (UTF-8).
- Confirma seleccionando Exportar en la siguiente pantalla.
Solucionar el problema de datos que aparecen en una sola columna
Si todos los datos de tus contactos aparecen en una sola columna después de abrir tu archivo CSV, es posible que el archivo esté usando un punto y coma o una tabulación como delimitador en lugar de una coma. La herramienta de importación de Kajabi requiere valores separados por comas. Para solucionar esto en Excel en Windows:- Abre un libro de Excel en blanco.
- Haz clic en la pestaña Data.
- Haz clic en From Text/CSV.
- Selecciona tu archivo CSV y haz clic en Import.
- En la ventana de vista previa, configura el menú desplegable Delimitador en Coma.
- Haz clic en Load para importar los datos en columnas separadas.
- Guarda el archivo como CSV UTF-8 (Comma delimited) usando File > Save As.
- Abre el archivo CSV en un editor de texto sin formato, como TextEdit.
- Verifica si los valores están separados por punto y coma, tabulaciones u otro carácter en lugar de comas.
- Usa Edit > Find > Find and Replace para reemplazar todos los puntos y coma o tabulaciones por comas.
- Guarda el archivo y vuelve a abrirlo en Numbers para confirmar que las columnas sean correctas.
- Exporta como CSV UTF-8 siguiendo los pasos de la sección Format in macOS más arriba.